Bug en Android compromete seguridad en Nexus 5 y 6

Pone en riesgoa equipos que usan kernel 3.4, 3.10 y 3.14.

android-caido

Bug en Nexus 5 y 6 corren riesgo de ataque debido al mal parche que se hizo del kernel.

Android sigue siendo víctima de vulnerabilidades. Ahora se encontró un bug que afecta a varios modelos de tablets y smartphones Nexus pero de forma general, a todos los que usan un determinado kernel en ese sistema operativo.

El problema se presenta a una vulnerabilidad detectada en Linux, que aunque se conocía y supuestamente se parchó hace dos años, no se hizo bien por lo que el problema persiste, ya que una app que sirve para hacer root puede aprovecharla, para apropiarse de los privilegios en las versiones kernel 3.4. 3.10, 3.14, usadas en Nexus 5 y Nexus 6, para ejecutar un malware. Las versiones a partir de la 3.18 no tienen problema.

Esta vulnerabilidad es considerada como crítica, ya que sería necesario reflashearlo para poder reparar al sistema operativo. La buena noticia es que si el equipo no accede a un exploit local, por lo que los ataques vía web son prácticamente imposibles.

Como medida preventiva, Google eliminó la app que se aprovechaba del hueco de seguridad y actualizó la opción que verifica las apps para bloquear la instalación de las enfocadas a realizar roots.

Con información de Android